MAC Layer pada Wireless Sensor Network — SMAC (Bagian Kedua) — Adaptive Listening dan Message Passing

Kita akan melanjutkan pembahasan tentang Sleep MAC (S-MAC) setelah sebelumnya membahas cara S-MAC mengurangi overhearing. Kali ini kita akan masuk tahap berikutnya dari penyempurnaan S-MAC, yaitu multihop awareness dan adaptive listening. Karena WSN adalah suatu jaringan terdistribusi yang multihop, maka multihop awareness dan adaptive listening sangat diperlukan, mengingat protokol dasar S-MAC hanya berfungsi untuk mengirim data per 1 hop untuk tiap framenya.

 

Perhatikan topologi gambar di bawah ini :

 

Multihop Awareness pada S-MAC

Multihop Awareness pada S-MAC

 

Ketika A mengirim data ke D melalui B dan C, maka ketika A mengirimkan RTS ke B, maka titik sensor C, H dan E akan menerima paket yang bukan ditujukan kepada mereka, serta memasuki mode sleep untuk mengurangi overhearing. Data pun bisa dikirim dari A ke B dengan aman. Tapi disinilah masalahnya! B ingin mengirim data melalui C tapi ternyata C masih dalam kondisi sleep! Berarti B harus menunggu sampai interval listen berikutnya baru bisa mengirim data ke C.

 

Seperti yang sudah dijelaskan sebelumnya, S-MAC mengurangi konsumsi energi berlebihan dengan delay sebagai tradeoff (tukar). Dengan mengorbankan delay, konsumsi energi bisa dikurangi. Tapi S-MAC memiliki suatu cara mengurangi delay lokal dengan metode adaptive listening.

 

Mekanisme kerja adaptive listening pada S-MAC dapat dilihat pada gambar dibawah ini :

 

Adaptive Listening pada SMAC

Adaptive Listening pada SMAC

 

Ketika titik sensor A berkomunikasi dengan B melalui RTS-CTS, titik sensor C akan mendengarnya dan memasuki kondisi sleep. Tapi titik sensor C juga mendapat informasi tentang durasi lamanya koneksi yang terjadi antara A dan B. Sehingga titik sensor C menetapkan timer yang akan habis pada waktu komunikasi antara A dan B selesai. Sehingga titik sensor C bisa menyala tepat ketika B memerlukannya sebagai next hop.

 

Jika ada titik sensor lain di dalam jangkauan titik sensor B yang ikut mendengarkan komunikasi RTS-CTS antara A dan B maka titik-titik sensor itu juga akan menjalankan mekanisme adaptive listening untuk berjaga-jaga apabila mereka yang terpilih sebagai next hop.

 

Sayangnya, metode ini hanya bisa dilakukan satu kali saja, karena pendekatan ini bersifat lokal dari titik sensor B. Jika C ingin mengirimkan data ke D, maka dia harus menunggu selama 1 frame lagi. Pendekatan adaptive listening pada S-MAC bisa mengurangi latency sebanyak separuh awalnya.

 

Kelemahan pendekatan adaptive listening adalah ada kemungkinan konsumsi energi yang digunakan untuk pemrosesan (misalnya untuk menentukan timer mundur) bertambah. Juga konsumsi energi yang digunakan ketika titik sensor hidup kembali dan berjaga-jaga jika dirinya terpilih sebagai next hop, karena ini termasuk overhearing (meskipun tidak sebanyak tanpa adaptive listening).

 

Satu lagi pendekatan untuk S-MAC adalah Message Passing. Dalam aplikasi tertentu (tidak seluruhnya), sebuah titik sensor kadang harus mengirimkan untaian paket karena paket tersebut terlalu besar jika dikirim sekaligus. Untaian ini terdiri dari beberapa potongan paket yang diberi tanda urutan. Tentu jika menggunakan komunikasi RTS-CTS untuk tiap paket ini akan sangat membuang waktu. Prosedur message passing sangat berguna dalam kasus ini. Komunikasi RTS-CTS hanya dilakukan ketika pengiriman paket paling pertama dari untaian paket tersebut. Setiap pengiriman paket tetap diselangi dengan komunikasi ACK untuk menjaga keutuhan paket data.

 

Message Passing pada SMAC (Aplikasi Tertentu)

Message Passing pada SMAC (Aplikasi Tertentu)

 

Selain itu, durasi dari pengiriman untaian paket data juga dimasukkan ke dalam tiap paket, untuk menjaga agar selama pengiriman terjadi tidak ada titik sensor lain yang berusaha menggunakan channel. Cara kerjanya adalah : jika ada titik sensor lain yang terbangun ketika untaian paket sedang dikirim, maka dia akan menerima paket ACK yang seharusnya ditujukan untuk A. Karena menerima paket data yang bukan untuknya, maka titik sensor itu akan kembali memasuki sleep mode.

 

Secara garis besar, S-MAC mengorbankan latency demi energy conservation. Bukan ide yang buruk bagi WSN, hanya saja S-MAC tidak disarankan untuk aplikasi WSN yang bersifat delay-sensitive (mementingkan kecepatan transmisi).

 

Sekian penjelasan S-MAC dari saya, berikutnya nanti kita akan membahas pendekatan MAC Layer lainnya dari WSN, yaitu B-MAC (Berkeley MAC)

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

 

MAC Layer pada Wireless Sensor Network — SMAC (Bagian Pertama) — Sinkronisasi Penjadwalan Node dan Overhearing Avoidance

Sebelumnya kita telah membahas mekanisme CSMA/CA dan peranannya dalam Wireless Sensor Network. Nah, kali ini kita akan membahas tantangan pendekatan MAC Layer lainnya pada WSN yaitu menghindari idle listening.

Kelemahan dari CSMA/CA adalah rentan terhadap idle listening, karena tiap titik sensor harus mendengarkan apakah saluran tidak dipakai sebelum mengirimkan suatu data. Idle Listening sangat memakan energi karena jika mendengarkan dan memroses data yang tidak ditujukan untuk dirinya, maka konsumsi energi akan sia-sia.

Salah satu pendekatan MAC Layer WSN berbasis CSMA/CA adalah Sleep MAC (S-MAC). Protokol ini memperkenalkan duty cycle operation dimana aktivitas suatu titik sensor dijadwalkan berdasarkan suatu penjadwalan waktu yang disebut frame. Selama frame ini berlangsung, titik sensor akan memasuki kondisi sleep selama satuan waktu tertentu dan wake-up sepanjang sisa frame. Rasio antara durasi wake-up dan panjang frame keseluruhan disebut duty cycle.

Tiap frame terdiri atas 2 interval, listen dan sleep. Interval listen dibagi lagi menjadi 2 interval, yaitu Sync dan Data. Metode synchronization messages digunakan untuk penentuan panjang interval tiap frame, menggunakan pesan SYNC.

Bagian-bagian Suatu Frame

Bagian-bagian Suatu Frame

Sekarang kita masuk ke penjelasan mekanisme kerja untuk sinkronisasi penjadwalan. S-MAC memastikan bahwa beberapa titik sensor dalam radius transmisi yang saling terhubung satu sama lain tersinkronisasi dengan 1 penjadwalan yang sama. Hal ini dilakukan dengan pertukaran pesan SYNC. Struktur pesan SYNC terdiri atas ID titik sensor pengirim dan sisa waktu yang ada sampai titik sensor pengirim memasuki mode sleep.

Struktur Pesan SYNC

Struktur Pesan SYNC

Selama inisialisasi protokol, titik sensor akan mendengarkan apakah ada yang mengirimkan pesan SYNC. Jika tidak ada, maka titik sensor tersebut akan mengumumkan penjadwalannya sendiri dan mem-broadcast pesan SYNC. Titik sensor yang mengirimkan pesan SYNC disebut synchronizer. Titik sensor lainnya yang mendengar pesan SYNC dan mengikuti penjadwalan synchronizer disebut follower. Jadwal sleep berisikan sisa waktu sampai titik sensor memasuki mode sleep.

Ada kemungkinan sebuah titik sensor menerima pesan SYNC setelah dirinya menentukan penjadwalan sendiri. Dalam kasus ini, titik sensor harus beradaptasi dengan kedua penjadwalan. Titik sensor dalam kasus ini disebut Border Node. Hubungan synchronizer, follower dan border node dapat dilihat pada gambar dibawah :

Hubungan Antara Synchronizer, Follower dan Border Node

Hubungan Antara Synchronizer, Follower dan Border Node

Mekanisme CSMA/CA akan digunakan untuk mengirim data pada saat interval DATA dimulai. Dapat dilihat pada gambar dibawah bahwa proses pengiriman data menggunakan pertukaran pesan RTS-CTS, ciri khas CSMA/CA.

CSMA/CA pada S-MAC

CSMA/CA pada S-MAC

Metode overhearing avoidance juga digunakan untuk menghemat energi. Ketika paket RTS-CTS selesai dan DATA mulai dikirim, titik sensor yang lain (kecuali yang sedang berkomunikasi) akan memasuki mode sleep untuk menghindari overhearing. Hal ini dilakukan dengan memeriksa paket RTS-CTS, apakah ditujukan untuk dirinya atau bukan. Jika bukan, maka titik sensor memasuki sleep.

Sejauh ini, kita dapat menyimpulkan bahwa kelemahan protokol S-MAC adalah protokol ini hanya mengatur interaksi lokal tiap titik sensor pada WSN. Secara spesifik, protokol ini hanya beroperasi dalam 1 hop. Perhatikan gambar di bawah ini :

Multihop Awareness pada S-MAC

Multihop Awareness pada S-MAC

Masalah ini disebut multihop awareness. Pada gambar, titik sensor A hendak mengirim data ke titik sensor D melalui B dan C. Selesainya melakukan komunikasi RTS-CTS, maka titik sensor C,H dan E akan memasuki sleep. Titik sensor A akan bisa mengirim data dengan aman ke B. Tapi ketika titik sensor B mencoba mengirimkan data ke titik sensor C, ternyata C masih dalam kondisi sleep! Hasilnya, dalam 1 frame, data hanya bisa melompat sejauh 1 hop saja. Dalam WSN yang memiliki arsitektur multihop, jelas hal ini merugikan dalam hal delay time.

Idealnya, tiap next hop harus memasuki kondisi listen ketika transmisi pada hop sebelumnya selesai. Tapi hal ini sangat sulit diimplementasikan pada WSN karena memerlukan network-wide synchronization pada umumnya. Tapi masih ada penyelesaian secara lokal, yaitu menggunakan adaptive listening. Tapi metode ini akan kita bahas pada postingan berikutnya, agar pembaca dapat memahami ­step-by-step penyempurnaan metode pendekatan S-MAC ini.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

MAC Layer pada Wireless Sensor Network — CSMA dan CSMA/CA

Sebelumnya, kita telah membahas apa itu Wireless Sensor Network (WSN) dan bentuk protocol stacknya. Kali ini kita akan membahas satu per satu layer protokol tersebut. Kita mulai dari layer 2, yaitu MAC protocol. Kenapa kita tidak mulai dari layer pertama? Karena medium access adalah salah satu fungsi terpenting pada pembatasan WSN, yaitu penghematan energi.

 

Beberapa pendekatan protokol MAC telah dilakukan dan diklasifikasikan menjadi 3 jenis, yaitu contention-based medium access, reservation-based medium access dan hybrid solutions. Ketiga solusi tersebut bergantung pada 2 skema fundamental medium access, yaitu Carrier Sense Multiple Access (CSMA) dan Time Division Multiple Access (TDMA).

 

Dari beberapa protokol MAC untuk WSN yang sudah dikembangkan, semua berfokus kepada 2 metric, yaitu throughput dan latency. Tapi kedua metric ini tetap berada di bawah fokus utama seluruh layer protokol WSN, yaitu penghematan energi.

 

Konsumsi energi pada WSN terjadi pada 3 fungsionalitas utamanya, yaitu pengindraan, pemrosesan data dan transmisi data. Tapi transmisi data adalah fungsionalitas yang paling memakan energi. Karenanya, komunikasi harus diatur sedemikian rupa untuk menciptakan operasi hemat energi pada WSN.

 

3 usaha komunikasi yang paling memakan energi adalah :

  1. Idle Listening : Kasus dimana radio beroperasi tapi tidak ada data berguna yang bisa diambil dari channel. Pendek kata, menyala disaat tidak terpakai. Ini bisa berakibat overhearing, yaitu mengolah/menerima data yang bukan untuknya.
  2. Collision : Tabrakan data sering terjadi ketika 2 titik sensor yang berdekatan mengirim paket ke receiver yang sama dalam waktu yang hampir bersamaan. Tabrakan data membuat receiver tidak menerima data yang manapun. Karena sifat half-duplex tidak memungkinkan deteksi tabrakan data, pencegahan tabrakan data biasanya dieksploitasi di MAC.
  3. Protocol overhead : untuk mengontrol komunikasi di kanal nirkabel, MAC membutuhkan transmisi paket kontrol. Paket ini juga perlu diminimalisasikan ukurannya untuk menghemat energi.

 

Jalan terpenting untuk menghemat energi pada WSN adalah dengan mematikan sirkuit transceiver. Radio dalam posisi ini bisa beraktifitas dalam keadaan sleep yang biasanya dilakukan ketika titik sensor tidak memiliki paket yang perlu dikirim/diterima dalam periode waktu tertentu. Ini merupakan tantangan terbesar dalam pengembangan protokol MAC WSN.

 

Selain itu, tantangan untuk pengembangan protokol MAC pada WSN juga bergantung pada arsitektur jaringan. WSN bisa terdiri dari ribuan titik sensor yang ditebarkan sekaligus dalam suatu medan, sehingga jumlah sensor neighbor yang bisa dicapai oleh suatu sensor bisa menjadi kerugian sekaligus keuntungan. Jika sensor neighbor yang bisa dicapai cukup banyak, maka kemungkinan terjadinya tabrakan data semakin besar. Tapi jumlah neighbor yang cukup banyak bisa membantu dalam hal konektivitas, mengingat titik sensor juga bertindak sebagai router.

 

Sebagian besar protokol MAC pada WSN menyarankan penggunaan CSMA. CSMA digunakan sebagai protokol komunikasi dasar pada contention-based protocol dan sebagai pengaturan slot request pada reservation-based protocol. Cara kerja CSMA secara garis besar adalah listen before transmit. Sebelum mengirim data, titik sensor akan mengumpulkan informasi apakah channel sedang dipakai atau tidak. Waktu yang digunakan untuk pengumpulan informasi ini disebut interframe space (IFS). JIka selama IFS channel dianggap kosong, maka pengiriman akan dilakukan. JIka tidak, maka titik sensor akan menunggu transmisi tersebut selesai lalu menunggu lagi selama 1 periode IFS.

 

Sekarang disini masalahnya. Jika terdapat 3 titik sensor neighbor yang ingin mengirimkan data ke tujuan, pasti akan terjadi tabrakan data. Untuk mencegahnya, terdapat metode backoff. Cara kerjanya seperti berikut :

 

  1. Setelah transmisi yang terdeteksi selesai, titik sensor akan menunggu selama 1 periode IFS lagi.
  2. Jika tidak terdeteksi apa-apa, maka titik sensor akan memilih secara semiacak (pseudorandom) nomor slot dalam satu periode waktu tertentu sebelum mengirim paket. Timer pun berjalan.
  3. Setelah titik sensor mencapai periode backoff, titik sensor yang berada pada slot paling awal (timer habis paling awal) diizinkan mengirim paket.
  4. Titik sensor yang lain akan mem-pause timer masing-masing dan me-restartnya setelah transmisi selesai.

 

CSMA dengan Mekanisme Backoff

CSMA dengan Mekanisme Backoff

 

Tapi, dalam suatu jaringan yang memiliki banyak titik seperti WSN, berarti banyak pula titik sensor yang harus memilih slot waktu yang jumlahnya terbatas. Untuk mengatasinya, jika ada beberapa titik yang memilih slot yang sama, maka mereka harus melipatgandakan nilai slot mereka dan memilih periode backoff atau slot waktu yang baru.

 

Lalu bagaimana jika data yang dikirim ternyata tidak sampai ke tujuan? CSMA dasar tidak memiliki kemampuan untuk mendeteksi kegagalan pengiriman di tengah jalan. Untuk itu, sebuah metode pencegahan (bukan pendeteksian!) tabrakan data diimplementasikan dalam CSMA, menjadi CSMA/CA (Carrier Sense Multiple Access with Collision Avoidance).

 

Contoh tabrakan data yang mungkin terjadi walaupun sudah menggunakan metode backoff adalah hidden terminal problem. Perhatikan gambar dibawah ini :

 

Hidden Terminal Problem

Hidden Terminal Problem

 

Ketika titik A mengirim paket ke titik B, maka titik C, D dan E bisa mendengarnya dan menghentikan backoff timer mereka (metode backoff) selama transmisi tersebut berlangsung. Tapi titik G, H dan I hanya bisa mendengar titik B. Alhasil, mereka tidak mengetahui bahwa sebentar lagi B akan menerima paket dari A. Jika mereka mengirim paket juga ke B maka akan terjadi tabrakan data.

 

CSMA/CA bekerja seperti berikut :

 

Cara Kerja CSMA/CA

Cara Kerja CSMA/CA

 

Setelah menerima gilirannya dalam pengiriman (backoff timer habis) maka titik sensor akan menunggu dengan waktu yang lebih sedikit dari IFS. Setelahnya, titik sensor akan mengirimkan paket Request to Send (RTS). Titik sensor tujuan akan menerimanya dan menungg sejenak, lalu mengirimkan paket Clear to Send (CTS) jika saluran kosong. Barulah dimulai pengiriman data. Setelah data terkirim, titik sensor akan menunggu sejenak lalu mengirimkan paket ACK. Setelah paket ACK diterima oleh titik sensor pengirim, barulah transmisi selesai dan backoff timer titik sensor lainnya bisa berjalan lagi.

 

Sejauh ini, permasalahan dalam MAC pada WSN baru kita bahas tentang menghindari collision saja. Di postingan berikutnya, kita akan membahas pendekatan-pendekatan MAC Layer secara lebih spesifik satu-per-satu, sekaligus membahas permasalahan lainnya seperti Idle Listening dan Protocol Overhead.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Active Directory Windows Server 2003 — Membuat User, Group dan Log On dari PC Klien

Setelah sebelumnya mengenal apa itu Active Directory dan cara kerjanya, mari kita memulai untuk masuk lebih dalam. Di postingan sebelumnya telah dikatakan bahwa Active Directory memiliki sebuah basis data untuk menyimpan segala hal yang berkaitan dengan jaringan komputernya, seperti komputer mana saja yang tergabung dengan domainnya, daftar akun pengguna serta group masing-masing, folder sharing dan lain sebagainya. Sekarang kita akan memulai membuat akun-akun tersebut.

 

Buka Start – Programs – Administrative Tools – Active Directory Users and Computers. Di tulisan dengan nama domain yang anda buat sebelumnya,, klik tanda (+) lalu klik kanan pada sub-folder User. Sorot New – User. Isi sesuai yang anda inginkan, lalu klik Next.

 

Mendaftarkan User Baru

Mendaftarkan User Baru

 

Masukkan password yang anda inginkan dan ikuti prompt tersebut sampai Finish.

 

Oke, sekarang kita memiliki sebuah akun user. Lalu kita ingin mengelompokkan beberapa akun user menjadi suatu grup. Langkahnya sama, hanya saja setelah klik kanan sub-folder User, sorot New – Group. Isikan nama grup lalu ikuti prompt sampai Finish.

 

Menambahkan Group

Menambahkan Group

 

Berikutnya, memasukkan suatu user sebagai anggota suatu grup. Klik kanan nama user anda dan pilih Add to a group. Masukkan nama grup yang anda inginkan (Check dulu untuk memastikan kebenaran nama grup). Lalu klik OK. Untuk memeriksanya, klik kanan nama user dan Properties. LIhat sub-tab Member of.

 

User yang sudah masuk ke suatu Group

User yang sudah masuk ke suatu Group

 

Oke, sekarang kita memiliki user dan group. Apa gunanya? Tentu saja banyak. Yang mendasar adalah kita bisa login dari komputer Windows yang 1 LAN dengan server kita menggunakan akun ini! Nyalakan 1 komputer lagi (saya menggunakan Windows XP SP2 di klien) dan masukkan ke LAN yang sama dengan server.

 

Lalu klik kanan My Computer – klik Properties. Masuk ke sub-tab Computer Name dan klik Change. Masukkan nama domain kita lalu klik OK. Masukkan user dan password yang terdaftar pada server kita tadi. Lalu klik OK dan restart PC klien.

 

Tab Properties pada My Computer PC Klien

Tab Properties pada My Computer PC Klien

 

Memasukkan Username dan Password yang terdaftar di Server ke Klien

Memasukkan Username dan Password yang terdaftar di Server ke Klien

 

Jika terjadi error saat ingin memasukkan user dan password pada PC klien, buka Properties user kita dan masuk ke sub-tab Account. Hapus tanda centang pada User must change password at next logon. Jika berhasil, akan tampak seperti pada gambar dibawah.

 

Sukses masuk ke domain

Sukses masuk ke domain

 

Ketika log on di komputer klien, ubah radio-option Log on to menuju ke domain server kita.

 

Log On ke Server

Log On ke Server

 

Dan masuklah kita ke dalam domain yang kita buat di server menggunakan Active Directory sebelumnya!

 

Cukup sampai disini tutorial kita kali ini, semoga bermanfaat bagi kita semua.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Pengenalan Active Directory pada Windows Server 2003

Karena selama ini saya terlalu banyak membahas Linux Server, mungkin sudah waktunya untuk mencoba berganti suasana dengan menggunakan Windows Server. Kenyataannya, Windows Server juga banyak dipakai di perusahaan enterprise, terutama di bidang multimedia. Dalam tutorial kali ini saya akan menggunakan Windows Server 2003 R2 Standard SP2 64 bit. Cara instalasi tidak akan saya jelaskan karena sama saja dengan instalasi Windows lainnya.

 

Yang akan saya bahas untuk pertama kali adalah Active Directory (AD). AD adalah layanan direktori yang terdapat pada Windows Server. Fungsi layanan AD adalah mengorganisir, menyimpan dan mengatur/manajemen data direktori. Struktur layanan AD mengikuti format protokol ISO X.500, yaitu struktur hirarki yang bisa dilihat di gambar berikut ini :

Format Hirarki Protokol X.500

Format Hirarki Protokol X.500

 

AD memiliki sebuah basis data untuk menyimpan segala hal yang berkaitan dengan jaringan komputernya, seperti komputer mana saja yang tergabung dengan domainnya, daftar akun pengguna serta group masing-masing, folder sharing dan lain sebagainya. Untuk manajemen data, layanan AD mengimplementasikan Lightweight Directory Access Protocol (LDAP) yang merupakan penerus Directory Access Protocol (DAP) dari X.500. LDAP biasanya menggunakan port TCP 389 sebagai koneksi transportasi utamanya. Sebagai penunjuk lokasi layanan, AD menggunakan Domain Name Service (DNS).

Sebelum ada layanan AD, Windows (pada waktu itu Windows NT 4.0) menggunakan NetBIOS (Network Basic Input-Output System) untuk merepresentasikan domain. Domain-domain yang menggunakan NetBIOS ini memiliki satu basis data pengatur user/group/policy yang disebut Security Accounts Manager (SAM). SAM terletak di dalam server utama yang disebut Primary Domain Controller (PDC). Nama dbatasi 15 karakter, sementara karakter ke-16 merupakan NetBIOS suffix yang berguna untuk mengidentifikasi layanan yang terinstalasi pada sistem tersebut.

Untuk menambah reliabilitas, Microsoft menambahkan server “bantuan” ke dalam sistem NetBIOS, yang disebut Backup Domain Controller (BDC). BDC menyimpan versi read-only dari basis data SAM PDC. Pengguna mengakses BDC ketika log on ke suatu domain tapi perubahan basis data SAM hanya bisa dilakukan di PDC. Hubungan PDC-BDC adalah master-slave. Jika PDC mengalami kegagalan sistem, maka salah satu BDC bisa direkomendasikan menjadi PDC pengganti serta policy akan diubah menjadi write-enable.

Sementara pada AD, sistem PDC-BDC tidak lagi digunakan. Seluruh domain controller dianggap sama (walaupun terdapat beberapa sistem yang dianggap “sedikit lebih tinggi”). Sebuah prosedur yang disebut multi-master replication akan memastikan bahwa jika terjadi perubahan pada salah satu domain controller, perubahan tersebut akan direplikasi ke domain controller lainnya. Jadi hubungan master-slave digantikan oleh peer to peer antar domain controller.

Bagaimana jika kita memiliki sebuah server Windows NT 4.0 dan ingin menghubungkannya ke dalam domain Windows Server 2003? Untunglah, Windows Server 2003 memperbolehkan domainnya bekerja dalam mixed-mode. Mode ini memperbolehkan BDC (bukan PDC!) Windows NT 4.0 untuk berpartisipasi dalam domain Windows Server 2003. Metodenya adalah, dengan meng-upgrade BDC tersebut ke Windows Server 2003. Sayangnya, proses ini bisa menghancurkan sistem yang sudah terinstalasi di BDC.

Lalu jika tidak ada PDC, bagaimana BDC bisa bekerja, mengingat BDC adalah replika read-only dari PDC? Windows Server 2003 memiliki kemampuan yang disebut Flexible Single Master Operations (FSMO) yang sering disebut PDC Emulator. FSMO menjadikan Windows Server 2003 sebagai PDC (secara emulasi).

 

Sekarang mari kita mulai menginstalasi layanan AD pada Windows Server 2003 kita. Pertama, klik Start – All Programs – Administrative Tools – Configure Your Server. Akan muncul jendela wizard seperti di bawah ini :

Jendela Configure Your Server

Jendela Configure Your Server

 

Masukkan CD Windows Server 2003 anda dan klik Next, lalu pilih Next lagi. Pilih Domain Controller (Active Directory).

Memilih Peran Server sebagai Domain Controller

Memilih Peran Server sebagai Domain Controller

 

Pilih Next, lalu Next. Wizard instalasi layanan AD akan muncul seperti gambar dibawah ini :

Instalasi Active Directory

Instalasi Active Directory

 

Klik Next lalu pilih Domain Controller for a New Domain. Setelah itu klik Next lagi dan pilih Domain in a New Forest. Klik Next.

Masukkan nama domain anda, misalnya zwei.co.id.

Memasukkan Nama DNS

Memasukkan Nama DNS

 

Setelah itu klik Next lagi. Nah, kini kita diminta memasukkan nama NetBIOS domain. Masih ingat bahwa diatas saya terangkan bahwa Windows Server 2003 bisa berjalan dalam mixed-mode? Inilah yang akan digunakan untuk “menipu” BDC yang merupakan anggota suatu NetBIOS. Masukkan nama domain NetBIOS lalu klik Next.

Memasukkan Nama Domain NetBIOS Jika Ada

Memasukkan Nama Domain NetBIOS Jika Ada

 

Anda akan diminta memasukkan direktori tempat menyimpan AD. Setelahnya, klik Next lagi. Muncul jendela Shared System Volume. Bisa menggunakan harddrive lain asalkan formatnya NTFS. Setelah memilih, klik Next.

Karena kita belum menginstalasi DNS Server untuk domain kita ini, maka akan muncul jendela DNS Registration Dianostic. Pilih Install and Configure DNS Server on this Computer. Akan diminta memilih tipe izin. Pilih sesuai dengan jaringan anda, lalu klik Next.

Jendela DNS Registration Dianostic

Jendela DNS Registration Dianostic

 

Setelahnya, anda akan diminta memilih password. Klik Next maka instalasi AD akan dimulai.

Proses Instalasi Berjalan

Proses Instalasi Berjalan

 

Setelah selesai, klik Finish lalu restart komputer anda. Sekarang layanan AD sudah terinstalasi di server anda.

Instalasi Selesai

Instalasi Selesai

 

Cukup sekian penjelasan saya tentang Active Directory, di postingan berikutnya akan kita bahas lebih mendalam tentang penggunaan Windows Server 2003 ini.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Pengenalan Wireless Sensor Network dan ZigBee — IEEE 802.15.4 Standarization

Mungkin pembaca sudah tahu tentang Wireless Sensor Network, tapi bagi yang belum tahu, akan saya jelaskan perlahan tentang teknologi ini dan seberapa pentingnya dalam dunia jaringan komputer dan embedded system.

Wireless Sensor Network (WSN) adalah suatu teknologi komunikasi wireless antar perangkat pengindraan yang rendah daya, rendah biaya dan rendah performa. WSN terdiri atas sejumlah besar titik sensor yang ditebarkan ke suatu area tertentu untuk kepentingan pengindraan. Berbeda dari jaringan komputer yang biasa kita kenal (OSI Layers atau DoD), yang diutamakan oleh WSN adalah penghematan energi, karena biasanya WSN digunakan untuk pengindraan daerah-daerah yang tidak bisa dijangkau manusia dan pengisian ulang energi hampir mustahil.

Karena banyak vendor yang membuat perangkat WSN, maka sebuah standarisasi harus diciptakan untuk menjaga kompatibilitas arsitektur hardware dan software. WSN menggunakan standarisasi IEEE 802.15.4 yang merupakan standarisasi untuk teknologi wireless dengan datarate rendah (jarang mengirimkan data). Untuk komunikasi, sering digunakan band 2,4 GHz untuk wilayah global, 915 MHz untuk wilayah Amerika dan 868 MHz untuk wilayah Eropa.

Salah satu standarisasi yang terhubung cocok dengan IEEE 802.15.4 dalam protocol stack adalah ZigBee. Dapat dilihat di gambar di bawah ini :

 

Layer-Layer IEEE 802.15.4 dan ZigBee

Layer-Layer IEEE 802.15.4 dan ZigBee

 

Sesuai dengan gambar, untuk layer fisikal dan media access control menggunakan IEEE 802.15.4 karena standar ini memang khusus untuk komunikasi Wireless Personal Area Network. Sementara bagian layer aplikasi dan network menggunakan standarisasi ZigBee.

 

Untuk mendukung berbagai macam kebutuhan aplikasi, tiga jenis traffic digunakan. Pertama, traffic periodik, yang biasa digunakan untuk aplikasi monitoring, dimana sensor mengirimkan data secara periodik terus menerus terhadap suatu fenomena fisik. Kedua, traffic berselang, yang biasa digunakan untuk aplikasi event-triggered. Biasanya yang menjadi trigger adalah sinyal dalam software atau faktor eksternal. TIpe traffic ini diatur oleh tiap titik router. Ketiga, traffic rendah latensi, digunakan oleh komunikasi tertentu yang memerlukan waktu proses singkat, misalnya proses ‘klik’ mouse oleh administrator.

Perbedaan utama antara WSN dan embedded system network lainnya adalah titik sensor pada WSN selain memiliki fungsi sensor juga memiliki fungsi sebagai router. Titik sensor biasanya bertebaran di dalam suatu medan. Tiap titik sensor ini memiliki kemampuan mengumpulkan data dan mengirimkannya menuju sink atau gateway (jika WSN terkoneksi ke jaringan luar). Data dikirim ke end user menggunakan arsitektur multihop.

Titik sensor juga bisa bertindak sebagai router untuk berpartisipasi dalam proses pengiriman data sebagai salah satu hop. Hal ini dikarenakan keterbatasan hardware dan penghematan energi, WSN menggunakan metode komunikasi rendah daya yang berarti jarak transmisi terbatas. Untuk mengatasinya, setiap titik sensor harus mengoper data ke titik sensor lainnya sampai akhirnya sampai ke sink.

Gambaran Wireless Sensor Network pada suatu Medan

Gambaran Wireless Sensor Network pada suatu Medan

Penggunaan WSN bervariasi di berbagai bidang seperti militer, pengamatan lingkungan, aplikasi rumahan dan kesehatan. Aplikasi di bidang militer misalnya Smart Dust dan Boomerang Sniper Detection. Smart Dust adalah salah satu proyek militer DARPA yang digunakan untuk sistem C4ISRT (command, control, communication, computing, intelligence, surveillance, reconnaissance and targeting). Berwujud sebuah kotak bervolume 100 milimeter kubik dengan 2 chip, yaitu chip MEMS (micro electro mechanical system) dengan sederet transmitter dan chip CMOS ASIC dengan receiver optik, charge pump dan digital controller. Smart Dust ditebarkan di medan perang/target dengan berbagai cara seperti pesawat pengebom tabur. Adapun Boomerang Sniper Detection System memiliki wujud berupa batangan yang dikelilingi mikrofon untuk mendeteksi suara tembakan halus sniper rifle. Biasa ditaruh di kendaraan perang atau dibawa oleh tentara reconnaissance.

 

Smart Dust

Smart Dust

 

Boomerang Sniper Detection System

Boomerang Sniper Detection System

 

Cukup sekian penjelasan tentang Wireless Sensor Network kali ini, di postingan berikutnya akan kita kupas lebih mendalam lagi tentang teknologi mutakhir ini.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Konfigurasi Routing Statis dan Route Summarization menggunakan Vyatta 6.5R1

Kita pernah membahas tentang routing, baik statis maupun dinamis. Sekarang kita akan mempelajari kegunaannya langsung di dalam dunia nyata. Saya akan menggunakan Vyatta 6.5R1 sebagai router untuk mendemonstrasikan tutorial ini.

Sekedar mengulas ulang, routing statis adalah salah satu manajemen routing dimana administrator memasukkan entry route ke network tujuan secara manual satu per satu. Manajemen routing ini sangat cocok untuk jaringan skala kecil, tapi akan menghabiskan banyak waktu jika digunakan untuk koneksi skala besar. Keuntungan dari routing statis adalah hemat resources, karena entry route sudah ditentukan sehingga mengurangi beban processing power untuk algoritma routing.

Pertama, kita buat rancangan jaringan seperti gambar di bawah ini :

Konfigurasi Pertama

Topologi Pertama

Setelah itu, kita berikan IP Address untuk masing-masing interface. Ketikkan configure sehingga masuk ke mode konfigurasi vyatta.

Vyatta 1 :

set interfaces ethernet eth0 address 192.168.0.1/24

set interfaces ethernet eth1 address 192.168.1.1/24

Vyatta 2 :

set interfaces ethernet eth0 address 192.168.1.2/24

set interfaces ethernet eth1 address 192.168.2.1/24

Vyatta 3 :

set interfaces ethernet eth0 address 192.168.1.3/24

set interfaces ethernet eth1 address 192.168.3.1/24

Jangan lupa untuk menyimpan dengan perintah commit dan save.

Berikutnya kita akan memasukkan routing statisnya. Perlu diingat kembali bahwa karena dalam routing statis ini kita menentukan sendiri jalur yang akan diambil beserta next-hop yang dipilih. Dalam kasus ini, bagi Vyatta 1, network 192.168.2.0/24 dan 192.168.3.0/24 adalah remote network yang bisa diakses melalui next-hop 192.168.1.2/24 dan 192.168.1.3/24.

Vyatta 1 :

set protocols static route 192.168.2.0/24 next-hop 192.168.1.2

set protocols static route 192.168.3.0/24 next-hop 192.168.1.3

commit

 

Begitu juga network 192.168.0.0/24 dan network 192.168.3.0/24 bagi Vyatta 2 :

Vyatta 2 :

set protocols static route 192.168.0.0/24 next-hop 192.168.1.1

set protocols static route 192.168.3.0/24 next-hop 192.168.1.3

commit

 

Dan remote network 192.168.0.0/24 serta 192.168.2.0/24 dari Vyatta 3 :

set protocols static route 192.168.2.0/24 next-hop 192.168.1.2

set protocols static route 192.168.0.0/24 next-hop 192.168.1.1

commit

Nah, kini semuanya sudah terkoneksi. Silakan beri IP Address yang sesuai network masing-masing pada PC klien dan ping satu sama lain.

Sekarang kita akan melakukan route summarization. Apa itu? Route Summarization adalah metode penentuan jalur routing  dengan cara merangkum pengalamatan IP Address network-network yang ada. Jadi kita tinggal melakukan sekali konfigurasi. Bingung? Baiklah, pertama buat dulu network baru seperti di bawah ini :

Topologi Route Summarization

Topologi Route Summarization

Gunakan perintah di bawah ini untuk menghapus konfigurasi yang sudah kita lakukan sebelumnya (ingat, kita harus mengulangi segalanya dari awal karena topologinya berbeda) :

delete interfaces

delete protocols

commit

save

 

Setelah seluruh router kembali fresh, mari kita mulai! Seperti biasa, berikan IP Address yang sesuai dengan network masing-masing :

Vyatta 1 :

set interfaces ethernet eth0 address 192.168.0.1/24

set interfaces ethernet eth1 address 192.168.2.1/24

commit

save

 

Vyatta 2 :

set interfaces ethernet eth0 address 192.168.1.1/24

set interfaces ethernet eth1 address 192.168.2.2/24

commit

save

 

Vyatta 3 :

set interfaces ethernet eth0 address 192.168.2.3/24

set interfaces ethernet eth1 address 192.168.3.1/24

commit

save

 

Vyatta 4 :

set interfaces ethernet eth0 address 192.168.3.2/24

set interfaces ethernet eth1 address 192.168.4.1/24

commit

save

 

Sekarang perhatikan lagi topologi kita yang baru. Bisa dilihat bahwa dari Vyatta 1 dan Vyatta 2, network 192.168.3.0/24 dan 192.168.4.0/24 bisa dicapai dari hop 192.168.2.3/24 milik Vyatta 3. Juga, network 192.168.0.0/24, 192.168.1.0/24 dan 192.168.2.0/24 bisa diakses oleh Vyatta 4 dari hop 192.168.3.1/24 milik Vyatta 3.

Kita mulai proses perhitungan route summarization. Dari sisi Vyatta 1 dan 2, kedua network akan digabungkan dengan gerbang AND :

11000000.10101000.00000011.00000000

11000000.10101000.00000100.00000000 AND

11000000.10101000.00000000.00000000

Perhatikan hasilnya, menjadi network 192.168.0.0/21! Network ini yang akan kita gunakan dalam konfigurasi pada Vyatta 1 dan 2 :

Vyatta 1 :

set protocols static route 192.168.0.0/21 next-hop 192.168.2.3

commit

save

 

Vyatta 2 :

set protocols static route 192.168.0.0/21 next-hop 192.168.2.3

commit

save

Berikutnya, dari sisi Vyatta 4 :

11000000.10101000.00000000.00000000

11000000.10101000.00000001.00000000

11000000.10101000.00000010.00000000 AND

11000000.10101000.00000000.00000000

Jadilah network 192.168.0.0/21! Implementasikan ke dalam route summarization :

Vyatta 4 :

set protocols static route 192.168.0.0/21 next-hop 192.168.3.1

commit

save

 

Tapi jangan lupa dengan Vyatta 3, karena posisinya di tengah dan route summarization tidak berlaku baginya di topologi ini, maka konfigurasi tetap dijalankan seperti biasa :

Vyatta 3 :

set protocols static route 192.168.0.0/24 next-hop 192.168.2.1

set protocols static route 192.168.1.0/24 next-hop 192.168.2.2

set protocols static route 192.168.4.0/24 next-hop 192.168.3.2

commit

save

 

Sekarang berikan PC Klien masing-masing IP Address yang sesuai dengan network dan lakukan ping. Hasilnya kira-kira akan jadi seperti di bawah ini :

Hasil Ping Vyatta 1 ke Network 192.168.4.0/24

Hasil Ping Vyatta 1 ke Network 192.168.4.0/24

Sekarang kita mengerti bahwa route summarization bisa membantu kita mengurangi konfigurasi dan waktu. Konfigurasi jadi lebih kompak, praktis dan tidak bertele-tele.

Sekian dulu tutorial dari saya, semoga berguna bagi kita semua.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Instalasi WordPress Menggunakan Nginx Pada Kubuntu 12.04 LTS

Sudah terlalu sering kita membahas protokol komunikasi, kali ini saya akan membahas sesuatu yang sangat dasar, yaitu instalasi CMS WordPress pada Kubuntu 12.04 LTS. Hal ini sangat dasar, tapi bahkan di forum internet sekalipun masih ada mereka yang mengalami beberapa error padahal tutorial yang mereka ikuti berhasil.

Dalam kasus saya, saya menggunakan sistem Operasi Kubuntu 12.04 LTS dan WordPress 3.5.1. Baiklah, tanpa banyak basa-basi, langsung saja!

Pertama, install MySQL dan Nginx dengan perintah di bawah :

sudo apt-get install mysql-server nginx

Lalu nyalakan layanan nginx dengan perintah sudo service nginx start.

Setelah itu, install php dengan perintah sudo apt-get install php5-fpm.

Kita perlu mengubah sedikit konfigurasi pada file php.ini. Buka file tersebut dengan nano :

sudo nano /etc/php5/fpm/php.ini

Dan cari baris bertuliskan “cgi.fix_pathinfo=1” dan ganti nilai 1 dengan 0. Apa maksudnya? Jika masih bernilai 1, maka php interpreter akan memproses file yang paling dekat dengan file yang diinginkan jika file tersebut tidak ada. Ini merupakan celah keamanan yang harus ditutupi.

Setelah menyimpan dan keluar, restart layanan php dengan perintah sudo service php5-fpm restart.

Berikutnya, kita akan melakukan konfigurasi terhadap Nginx. Buka file standar virtual host dengan perintah sudo nano /etc/nginx/sites-available/default.

Ubah bagian berikut :

  1. Tambahkan “index.php” di line index.
  2. Hilangkan tanda “#” pada bagian “location ~ \.php$ {“
  3. Tambahan, anda juga bisa mengganti isi server_name dengan domain name anda.

Kira-kira jadi seperti ini :

server {

        listen   80;

        root /usr/share/nginx/www;
        index index.php index.html index.htm;

        server_name zwei.com;

        location / {
                try_files $uri $uri/ /index.html;
        }

        error_page 404 /404.html;

        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
              root /usr/share/nginx/www;
        }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        location ~ \.php$ {
                #fastcgi_pass 127.0.0.1:9000;
                # With php5-fpm:
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;

        }

}

Berikutnya, kita membuat file php.info :

sudo nano /usr/share/nginx/www/info.php

Masukkan baris ini :

<?php
phpinfo();
?>

Lalu simpan dan keluar. Restart layanan Nginx dengan perintah sudo service nginx restart.

Sampai disini, kita sudah berhasil melakukan persiapan. Berikutnya, kita akan menginstall WordPress ke dalam Nginx. Download WordPress versi terbaru dengan perintah :

wget http://wordpress.org/latest.tar.gz

Lalu buka berkas dengan tar -xzvf latest.tar.gz

Kembali sebentar ke MySQL. Masuk ke shell MySQL dengan perintah mysql -u root -p dan masukkan password yang anda pakai ketika instalasi tadi. Kita akan membuat sebuah database, user dan passwordnya. Pertama, database :

CREATE DATABASE wordpress;
Query OK, 1 row affected (0.00 sec)

Kedua, user :

CREATE USER zwei@localhost;
Query OK, 0 rows affected (0.00 sec)
SET PASSWORD FOR zwei@localhost= PASSWORD("zwei");
Query OK, 0 rows affected (0.00 sec)

Terakhir, berikan izin kepada user dan refresh MySQL :

GRANT ALL PRIVILEGES ON wordpress.* TO zwei@localhost IDENTIFIED BY 'zwei';
Query OK, 0 rows affected (0.00 sec)
FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.00 sec)

Keluar dari shell MySQL dengan perintah exit. Sekarang waktunya konfigurasi WordPress. Pertama, kita harus meng-copy berkas contoh konfigurasi WordPress ke dalam berkas baru. Gunakan perintah :

cp ~/wordpress/wp-config-sample.php ~/wordpress/wp-config.php
sudo nano ~/wordpress/wp-config.php

Cari bagian yang mendefinisikan nama database, user dan password anda dan sesuaikan, misalnya seperti ini :

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define('DB_NAME', 'wordpress');

/** MySQL database username */
define('DB_USER', 'zwei');

/** MySQL database password */
define('DB_PASSWORD', 'zwei');



Simpan dan keluar. Selanjutnya buat direktori tempat kita akan menyimpan berkas WordPress. Gunakan perintah sudo mkdir -p /var/www dan copy berkas ke dalamnya dengan sudo cp -r ~/wordpress/* /var/www.

Untuk memudahkan update plugin WordPress dan file editing menggunakan SFTP, ubah izin akses direktori /var/www dengan perintah : 
cd /var/www/
sudo chown www-data:www-data * -R 
sudo usermod -a -G www-data zwei

Langkah berikutnya, kita harus mengaktifkan virtual host dari WordPress. Buat berkas baru dan copy format standar konfigurasinya :
sudo cp /etc/nginx/sites-available/default /etc/nginx/sites-available/wordpress
sudo nano /etc/nginx/sites-available/wordpress
Lakukan perubahan berikut : 
1. Ubah root ke /var/www/
2. Tambahkan index.php di line index
3. Ubah try_files $uri $uri/ /index.html; menjadi try_files $uri $uri/ /index.php?q=$uri&$args;
4. Hilangkan tanda “#” di bagian “location ~ \.php$ {“

Kira-kira seperti ini :

server {
        listen   80;

        root /var/www;
        index index.php index.html index.htm;

        server_name zwei.com;

        location / {
                try_files $uri $uri/ /index.php?q=$uri&$args;
        }

        error_page 404 /404.html;

        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
              root /usr/share/nginx/www;
        }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9$
        location ~ \.php$ {
                #fastcgi_pass 127.0.0.1:9000;
                # With php5-fpm:
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
                 }

}
Simpan dan keluar.

Terakhir, kita mengaktifkan server block dengan membuat symbolic link :
sudo ln -s /etc/nginx/sites-available/wordpress /etc/nginx/sites-enabled/wordpress
sudo rm /etc/nginx/sites-enabled/default

Install php5-mysql dengan perintah sudo apt-get install php5-mysql

Terakhir, restart layanan Nginx dan php-fpm :
sudo service nginx restart
sudo service php5-fpm restart

Dan konfigurasi selesai! Buka Web Browser anda dan arahkan ke <IP Address Server>/wp-admin/install.php dan tinggal ikuti wizard yang ada.
Wizard Instalasi WordPress

Wizard Instalasi WordPress

Sebelum mengakhiri tutorial ini, ada hal penting yang harus diingatkan. Jika anda mendapat error bahwa “The page is temporarily unavailable” maka jangan panik, itu berarti socket yang anda gunakan harus diganti. Buka berkas /etc/nginx/sites-available/wordpress dengan text-editor dan hilangkan tanda “#” pada baris fastcgi_pass 127.0.0.1:9000; serta tambahkan tanda “#” pada baris fastcgi_pass unix:/var/run/php5-fpm.sock;

Apa artinya? Kita mengubah socket yang dipilih oleh FastCGI server ke socket TCP yang lebih umum.

Sekian dulu postingan dari saya, semoga bermanfaat bagi anda semua.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Konfigurasi Keamanan Dasar Pada Router Cisco (2)

Oke, di postingan sebelumnya tentang “Keamanan Dasar pada Router Cisco (1)” kita sudah membahas tentang bagaimana cara mengamankan akses ke router baik dari akses fisikal menggunakan kabel console maupun akses remote menggunakan Telnet. Nah, kali ini kita akan melakukan hal yang lebih dalam lagi untuk mengamankan koneksi, yaitu memasukkan daftar user atau administrator yang bisa mengakses router, menentukan batasan hak akses mereka serta pencatatan tentang siapa saja yang mengakses router tersebut.

 

Pertama, buka kembali topologi yang kita buat di postingan sebelumnya. Ingat, bukankah kita sudah memasang password untuk masuk ke “routerku” melalui kabel console? Pertama, kita hilangkan dulu otentikasi tersebut dengan masuk ke bagian line console :

enable

configuration terminal

line console 0

no login

 

Setelah menghapus otentikasi tersebut, jangan keluar dulu dari line console, mari kita lihat apa saja yang bisa kita atur dari bagian ini. Ketikkan

login ?

 

Maka akan keluar beberapa pilihan seperti gambar dibawah ini :

 

Opsi yang terdapat pada pilihan Login

 

Jika memilih authentication maka kita akan menggunakan pengamanan AAA, yaitu kepanjangan dari Authentication (pengaturan sah/tidak sah dari sebuah username), Authorization (pengaturan batas hak akses suatu username) dan Accounting (pencatatan tentang username mana saja yang mengakses router tersebut). Untuk melakukan ini kita membutuhkan sebuah AAA Server, misalnya Radius Server. Tapi untuk sementara kita akan melakukan pilihan berikutnya yaitu local.

 

Mari kita aktifkan otentikasi tipe local ini. Masukkan perintah :

login local

end

 

Dan kita bisa mendaftarkan username serta password atau bahkan enkripsi yang kita inginkan. Mari kita daftarkan username sherlock. Untuk melihat atribut apa saja yang bisa kita pasangkan pada username ini, tambahkan tanda ‘?’ setelahnya :

username sherlock ?

 

Maka bisa kita lihat pilihan seperti gambar dibawah ini :

Opsi yang terdapat pada pilihan Username

 

Pilihan password sudah pasti tahu apa gunanya , kan? Pilihan privilege adalah untuk menentukan hak akses username tersebut. Sementara pilihan secret sama seperti sebelum-sebelumnya, yaitu menggunakan password terenkripsi. Kita akan menggunakan password terenkripsi :

username sherlock secret shellingford

end

 

Kita juga harus menghapus password otentikasi umum sebelumnya.

Password umum sebelumnya yang harus dihapus

 

Masuk ke global configuration mode dan masukkan perintah :

line console 0

no password

end

Sehingga bila diperiksa dengan perintah show running-config akan terlihat bahwa console memiliki tipe login local.

Sekarang keluar sepenuhnya dengan mengetikkan exit. Kemudian cobalah masuk lagi, maka kali ini anda akan diminta memasukkan username dan password seperti gambar dibawah ini :

Otentikasi username router

Password yang baik adalah password yang panjang, terdiri atas huruf, angka dan tanda baca serta tidak memiliki suatu “kata”. Nah, kita sebagai administrator utama harus mengingat hal ini. Kita bisa memberi peringatan tentang panjang minimum dari password jika seseorang ingin membuat username baru. Masuklah ke global configuration mode dan ketikkan :

security passwords min-length 8

end

Itu berarti kita menentukan panjang dari password untuk username yang akan dibuat berikutnya harus terdiri dari 8 atau lebih karakter. Sekarang masuk lagi ke global configuration mode dan buat username baru. Jika batas minimum tidak terpenuhi akan muncul peringatan seperti di bawah ini :

Peringatan ketika batas minimum password tidak terpenuhi

 

Sekarang kita akan melakukan pencatatan tentang siapa saja yang masuk, baik yang gagal maupun yang berhasil. Masuk ke global configuration mode dan masukkan perintah :
login on-failure log

login on-success log

exit

exit

 

Sekarang coba masuk lagi, begitu masuk maka akan muncul notifikasi tentang siapa saja yang masuk dan siapa saja yang gagal masuk, seperti gambar di bawah :

 

Notifikasi tentang siapa saja yang mengakses router

 

Bagaimana jika seseorang mencoba menebak password kita? Kita bisa menentukan jumlah attempt (percobaan) password kita dan lama waktu blokir jika jumlah attempt tersebut terlampaui, untuk mencegah dictionary attack. Mari kita masuk ke global configuration mode dan masukkan :

login block-for 3600 attempts 5 within 60

end

 

Itu berarti jika ada percobaan masuk yang gagal lebih dari 5 kali dalam 60 detik, maka akses ke router akan diblokir selama 3600 detik (1 jam).

 

Terakhir, kita akan mengatur timeout akses ke routerku melalui kabel console, yang standarnya adalah 10 menit. Mari kita masuk ke global configuration mode dan ubah menjadi 3 menit dengan perintah :

line console 0

exec-timeout 3

end

 

Dan timeout akses remote akan kita ubah menjadi 4 menit :

line vty 0 4

exec-timeout 4

end

 

Untuk melihat konfigurasi login kita, kita bisa masuk ke privileged user mode dan memasukkan perintah show login. Hasilnya seperti gambar dibawah :

 

Melihat apa saja yang sudah dikerjakan terhadap Login

 

Cukup sampai disini dulu sekarang, semoga apa yang saya tulis bermanfaat bagi kita semua.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!

Konfigurasi Keamanan Dasar Pada Router Cisco (1)

Sudah lama sekali tidak memposting sesuatu, dikarenakan saya sudah mulai mengerjakan Tugas Akhir dan waktu untuk ngoprek semakin berkurang (^_^). Tapi kali ini saya akan kembali mengenalkan dasar-dasar dari jaringan computer, kali ini menggunakan Cisco Packet Tracer.

Sebelumnya saya sudah pernah membahas banyak konfigurasi menggunakan Cisco Packet Tracer, seperti konfigurasi routing statis, RIP, OSPF dan lain sebagainya. Nah, kini saya akan kembali ke awal, yaitu pengamanan router dan device lainnya. Kenapa saya kembali ke awal, karena saya ingin postingan ini dan berikut-berikutnya akan membantu mereka yang ingin mengambil sertifikasi CCNA.

Kita langsung mulai saja, pertama marilah buat topologi seperti gambar berikut :

Topologi Dasar untuk Percobaan

 

Mungkin ada yang bertanya, kabel apa yang berwarna biru muda tersebut? Itu adalah kabel rollover atau kabel console. Kita bisa melakukan konfigurasi dari laptop yang terhubung dengan kabel rollover pada router tersebut atau langsung melalui router tersebut.

Mari kita coba mengonfigurasi router 0 dari laptop 0. Klik laptop 0, pilih tab Desktop dan pilih Terminal. Gunakan  Port Configuration standar dan klik OK. Maka tampilannya akan jadi seperti ini :

Membuka Hyper Terminal di PC

 

Nah, sama dengan ketika kita langsung memilih router 0 bukan?

Setelah itu masuk privileged user mode dengan mengetikkan enable dan masuk lagi ke global configuration mode dengan mengetikkan configuration terminal. Untuk lebih mudahnya, kita ubah dulu nama router 0 menjadi “routerku” dengan mengetikkan hostname routerku.

Berikan IP Address pada interface fa0/0 routerku dengan :

interface fastEthernet 0/0

ip address 192.168.0.1 255.255.255.0

no shutdown

exit

Setelah memastikan interface berjalan normal (ditandai dengan berubahnya titik merah menjadi hijau pada routerku), kita bisa melanjutkan. Untuk mengamankan routerku, ada 2 tipe pengamanan yang akan kita lakukan. Pertama, mencegah agar tidak sembarang orang bisa mengakses routerku dengan kabel rollover dan kedua, mencegah agar tidak sembarang orang bisa mengakses routerku secara remote baik menggunakan program semacam telnet atau SSH.

Untuk memahaminya, coba pilih routerku dan masuk ke tab Physical, disana kita akan menemukan 2 port yaitu console dan auxiliary. Port console sudah kita gunakan, sementara port auxiliary berfungsi untuk menghubungkan modem dengan routerku, sehingga kita bisa melakukan konfigurasi dengan cara dialing modem tersebut.

Physical Device View Tempat Port Console dan Port AUX Berada

 

Dalam percobaan ini kita akan melakukan pengamanan pada port console, karena port ini lebih mungkin disalahgunakan oleh orang lain. Masuk kembali ke global configuration mode dan ketikkan :

line console 0

password yahud

login

end

Apa yang kita lakukan dengan perintah-perintah diatas? Kita akan mengunci akses ke routerku lewat kabel console menggunakan password yaitu “yahud”.  Sehingga kita tidak bisa masuk tanpa mengetahui passwordnya.

Nah, itu tadi bagaimana cara mengamankan koneksi “fisikal” atau “langsung”. Bagaimana dengan akses remote seperti Telnet dan SSH? Seperti yang kita lihat pada topologi tersebut, routerku terhubung dengan sebuah PC melalui sebuah switch.

Pertama, kita harus mengaktifkan izin koneksi remote. Tentu saja sebaiknya diberi password. Aktifkan perizinan koneksi remote dengan masuk ke global configuration mode dan masukkan perintah :

line vty 0 4

password holmes

login

end

Maka akses terminal (misalnya Telnet dan SSH) bisa dilakukan melalui PC (tentu harus diberi IP Address yang sesuai dulu) tersebut. Masuk ke command prompt PC dan coba masuk melalui Telnet dengan password “holmes”. Kira-kira begini hasilnya :

Masuk Secara Remote dengan Telnet

 

Nah, kini baik akses langsung melalui kabel console maupun akses remote sudah diberi password. Sekarang apa lagi? Kita juga harus memberi perbedaan user biasa dan privileged user. Maka berilah password pada proses otentifikasi privileged user mode.Untuk koneksi remote ini harus dilakukan, atau anda tidak akan bisa masuk ke privileged user mode.  Lakukan dengan cara masuk ke global configuration mode dan masukkan perintah :

enable password watson

Maka kita bisa masuk ke privileged user mode dengan password “watson”, seperti pada gambar :

Masuk ke Privileged User Mode secara Remote

 

Tapi, sampai disinipun masih belum cukup! Jika kita melihat dengan perintah show running-config pada privileged user mode, kita bisa melihat bahwa password kita tadi bisa ditampilkan tanpa enkripsi. Ini menyebabkan siapapun bisa mengetahuinya jika mereka sempat melihat dengan perintah ini.
Untuk menutupinya kita bisa mengenkripsi password kita dengan apa yang disebut enkripsi Type 7. Caranya adalah masuk ke global configuration mode dan masukkan perintah

service password-encryption

exit

Dan setelahnya kita periksa lagi dengan show running-config pada privilege user mode. Terlihat bahwa password kita tadi sudah dienkripsi seperti gambar berikut :

Melihat Password yang sudah Dienkripsi Type-7

 

Tapi sayangnya enkripsi Type 7 ini mudah dipecahkan oleh beberapa algoritma “Cisco Password Cracking” yang biasa ada di situs-situs pemecah kode. Oleh karenanya kita lebih baik menggunakan algoritma hash MD-5 yang lebih aman.

Pertama, hapus password untuk masuk ke privileged user mode sebelumnya dengan perintah :

no enable password

exit

Lalu masuk ke global configuration mode dan masukkan perintah berikut :

enable secret Watson

Perintah sebelumnya yaitu enable passwordditambah service password encryption akan mengenkripsi password dengan enkripsi Type 7, tapi perintah enable secret akan langsung menggunakan hash MD-5. Hasilnya bisa dicek dengan perintah show running-config pada privilege user mode :

Menggunakan MD-5 sebagai Hash

 

Cukup sampai disini dulu bahasan tentang pengamanan dasar tentang router pada vendor Cisco. Bukan berarti hanya sampai disini, di postingan berikutnya saya akan menjelaskan tentang AAA Security dan Enhanced Login Features.

Untuk sekarang, Auf Wiedersehen und hoffen Sie einige gute Studien habenmeine Freund!!!